Exquis Drum Kit?

How do I access the Drum Kit as shown in the Exquis video tutorial? I have installed v1.0.1 of the Exquis application (on MacOS 13.6.3) along with Surge XT (1.3.0) and Speedrum Lite (1.0.3) and have loaded all the plugins in the app. All the other plugins seem to work but when I select Drum Kit nothing happens (if I just started the app) or the previous plugin stays loaded (if I had already been playing something else).

What am I missing here? Do I need another plugin? Am I missing a step to activate the drum kit?

1 Like

If speedrum is installed right and scanned as a VST3 plugin in the app, selecting « drum kit » category should show the presets (just like Surge XT presets in other categories).

This appears to be the problem but I guess I don’t understand the “right” way to install Speedrum. I started over with a fresh machine (MacOS 13.6.3) and downloaded & installed just the Exquis app (1.0.1) and Speedrum Lite (1.0.3). When I scan for plug-ins, the Exquis app seems to find Speedrum Lite but, when I go to the Sounds interface, there doesn’t appear to be any instruments (under drum kit or any other category).

What am I doing wrong here? How can I verify that Speedrum Lite is installed correctly? Am I supposed to do anything more than download Speedrum Lite and install its MacOS pkg?

I appreciate any help you can offer.

1 Like

I have the same problem.

macOS 10.14.6
Exquis app 1.0.1
SpeedrumLite 1.0.3

SpeedrumLite appears as a VST3 in the PlugIn list in the Exquis app.
I refreshed the Preset list.
When I click the Sounds button, I see SpeedrumLite in the VST3 list.

But when I click Factory, then DrumKit, no DrumKit presets appear.

Selection of presets works well for all other categories.

1 Like

Refresh preset lists from the app (alo automatically done when launching the app), and also check that the app has access to your files (« Full disk access » in System Preferences), it may come from things like that.

1 Like

Alas, this does not fix the problem on my end. I enabled Full Disk Access for the Exquis app in System Settings > Privacy & Security and refreshed the presets list in the app. I did this on both my production machine as well as the fresh test machine I have been using for troubleshooting and it didn’t work on either. I tried restarting the app, refreshing the Preset List, clearing the Plugin List and rescanning for VST3 plug-ins, as well as fully restarting the machine (I tried each of these multiple times, just to be sure).

Any other ideas? I appreciate your help in trying to figure this out. I would very much like to get this feature working on my Exquis.

@PeterHanes - Please let us know if @Serguei recommendations work on your setup.

If anyone else is having this problem, please chime in. Figuring out what the non-functioning setups have in common may help us figure out the fix.

FWIW, here is a screenshot showing the contents of my /Library/Audio/Plug-ins (for completeness, ~Library/Audio/Plug-ins in my user directory is empty) …

Also, here is a screenshot of what the Sounds interface in my Exquis app looks like …

I had already tried this but it did not solve the problem.

I tried this and it did not solve the problem.

I also tried all these things and none of them solved the problem.

1 Like

Can you try removing it from vst and only keep in in vst3 maybe ? (and the opposite if not working). Otherwise I am not sure we can help more…

@PeterHanes – Thanks for trying and sharing your results.

@Serguei – Unfortunately, your latest suggestion doesn’t seem to fix the problem. I tried the VST3, VST, and component individually and in every pairwise combination - with refresh, clear & rescan, and full app restarts between tests. Nothing appeared to change in any of the tests.

Could you provide a description of an installation that you know is working? Specifically, the version numbers for the operating system (preferably MacOS), the Exquis app (presumably 1.0.1 but perhaps 1.0.0 as in the video tutorial), and the Speedrum Lite plug-in (presumably 1.0.3 but who knows). If you can describe a known working configuration, I can try to stand up the same configuration at my end.

On a separate note, can you explain to me where the specific drum kits shown in the video tutorial come from? In other words, who defined the « Garage 1/2/3 », « LoFi 1/2 », and « Techno 1/2 » layouts (and how/where)? For reference, here is a screenshot of timestamp 6:34 from the video tutorial to illustrate what I am talking about …

I am not aware of Speedrum Lite coming with any such pre-configured kits. For example, when I use Speedrum Lite with Reaper, I always have to define my own drum kits by loading samples to the pads and saving the configuration.

Did you guys define these specific drum kits and the Speedrum Lite plug-in is just letting the Exquis app access them? If so, do I need to save my own Speedrum kits to some place that the Exquis app can see them?

1 Like

I tried deleting and reinstalling speedrum lite 1.0.3, then I tried your suggestion, and neither solved the problem.

1 Like

Not sure it will help you,

On Windows here is where it’s stored :

2 Likes

@Fil2 – Thank you very much. That helped me understand how the pieces fit together which allowed me to figure out a solution to the problem which I describe below.

@PeterHanes – If you have a chance to try the solution I found for my setup, I would be interested in hearing if it works on your setup.

The issue here is that the Mac version of the Speedrum Lite VST3 plug-in (v1.0.3) contains a file that declares the « Name » of the plug-in to be « SpeedrumLite » (without a space) instead of « Speedrum Lite » (with a space). On a Mac, this file can be found at …

/Library/Audio/Plug-Ins/VST3/SpeedrumLite.vst3/Contents/Resources/moduleinfo.json

You can edit this file to change the « Name » of the plug-in from « SpeedrumLite » (no space) to « Speedrum Lite » (with a space) on the second line of the file. I got to this file through the Terminal and I needed to sudo to edit it in pico. I did not need to change anything else in this file but I had to restart the Exquis app, clear the plug-ins list, and re-scan for VST3 plug-ins. Once I did those steps, I could see the « Speedrum Lite » plug-in, with the correct space in its name, and, when selecting Sounds > Factory > Drum Kit, I could see all the pre-configured Exquis drum kits as shown in this screenshot …

I suspect that what is happening under the hood is that the Exquis app is hard-coded to point a plug-in named « Speedrum Lite » (with a space) to the pre-configured drum kits. Since the moduleinfo.json file in the MacOS plug-in defines the name as « SpeedrumLite » (no space), the Exquis app fails to point the plug-in to the pre-configured drum kits. This is probably a packaging error in the MacOS version of Speedrum Lite but the Exquis app could probably verify that it has the right plug-in name to point to the pre-configured drum kits.

Finally, in case anyone wants or needs to dig into this further, the pre-configured drum kits, and the underlying samples, are located in the following location on MacOS …

This is the MacOS equivalent of the Windows file listing posted by @Fil2.

I hope that this information is useful to other MacOS Exquis users. Once I understood the problem, the fix was easy to implement. Please respond to this thread if you have tried this fix and whether it worked for you. If this fixes the problem in general for Mac users, I hope that the Exquis app developers can figure out a way to roll this into the MacOS version to make everything a little more seamless.

Thanks for everyone’s help and patience in figuring this out. I am looking forward to adding drum loops to my compositions. I am glad that this was included in the app.

Have fun, everybody!

5 Likes

I was able to do this on my Mac by opening the json file in TextEdit from the Finder.

After clearing and re-scanning the VST3 plugins, the preset drum kits showed up for me.

Agreed. Thank you very much for your diligence in diagnosing the problem.

Of further note for the Exquis app developers, the Speedrum Lite VST3 plug-in is the only one that shows up in the Plugin List window without a version number in the « Description » field. (The AudioUnit plugin does provide a number in its « Description » field.) Perhaps this indicates that a little more attention is required.

2 Likes

@PeterHanes – Awesome. I’m glad it fixed it for you.

2 Likes

Had this same issue, and this solved it for me.

Thank you @nuances ! I’m puzzled about how you figured this one out. Great job!

@Serguei I think this should be addressed in an upcoming software release. The Drum Kit feature is so crucial to the (intended/advertised) Exquis experience that it not working on a major platform like MacOS is a no-go.

1 Like

After 2 months, this issue is still not solved in Exquis app.
Hopefully, the patch proposed by @nuances solves this issue.
Thank you !